Ecosyste.ms: Timeline

Browse the timeline of events for every public repo on GitHub. Data updated hourly from GH Archive.

warden-protocol/wardenprotocol

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Remove duplicate status validation in `newSignRequestsRequest`** The validation of `input.Status` is performed twice. Removing the duplicate code strea...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Use Correct Capitalization for Initialisms in Function Names and Parameters** According to the [Uber Go Style Guide](https://github.com/uber-go/guide/blob/master/sty...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Consider indexing `creator` in `NewSignRequest` event for efficient event filtering** Indexing the `creator` address in the `NewSignRequest` event will...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Consider indexing `newOwner` in `AddSpaceOwner` event for better event filtering** Indexing the `newOwner` address in the `AddSpaceOwner` event will al...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Ensure consistent use of method receivers** Currently, the methods have a value receiver `(p Precompile)`. If `Precompile` is a struct that is large or may change st...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Refactor duplicated code to improve maintainability** Many event mapping functions share similar patterns for preparing event topics, parsing events, p...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Remove unused parameters from function signatures** Several functions have an unused parameter `_ *common.Address` in their signatures. Removing unused parameters im...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Inconsistent struct naming: Rename `keychainsRequestsInput` to `keychainsRequestInput`** The struct is named `keychainsRequestsInput`, which is inconsi...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Undefined type `TypesPageRequest` in `allKeysInput` struct** The type `TypesPageRequest` is not defined, which will cause a compilation error. Consider using `query....

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Consider adding tests for error handling and edge cases** While the test suite covers the main functionalities, incorporating tests for error condition...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Avoid using underscores in type names** According to the Uber Go style guide, underscores should not be used in type names. Consider renaming `Test_WardenPrecompile`...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Consider using structured error handling for 'checkAction' and 'voteForAction'.** The 'checkAction' and 'voteForAction' functions return string values,...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Correct the documentation to reflect that multiple actions are returned.** The summary for `actionsByAddress` should indicate that it queries multiple actions, not a...

View on GitHub

coderabbitai[bot] created a review on a pull request on warden-protocol/wardenprotocol
**Actionable comments posted: 18** <details> <summary>๐Ÿงน Outside diff range and nitpick comments (9)</summary><blockquote> <details> <summary>tests/cases/act_precompile.go (4)</summary><blockquote...

View on GitHub

coderabbitai[bot] created a review on a pull request on warden-protocol/wardenprotocol
**Actionable comments posted: 18** <details> <summary>๐Ÿงน Outside diff range and nitpick comments (9)</summary><blockquote> <details> <summary>tests/cases/act_precompile.go (4)</summary><blockquote...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Assign correct value to the `Authority` field in `msgAddSpaceOwner`.** In the construction of `msgAddSpaceOwner`, the `Authority` field is assigned the value of `act...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Remove duplicate status validation in `newSignRequestsRequest`** The validation of `input.Status` is performed twice in lines 385-387 and 389-391. This redundant cod...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Standardize struct name to `keychainsRequestInput`** The struct is currently named `keychainsRequestsInput`, which is inconsistent with naming conventi...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Enhance error handling in TemplateByIdQuery** Consider improving the error handling when calling the query server and unpacking the response. This will...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Enhance error handling in TemplatesQuery** Consider improving the error handling when calling the query server and unpacking the response. This will pr...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Enhance error handling in ActionsByAddressQuery** Consider improving the error handling when calling the query server and unpacking the response. This ...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Add input validation for Creator in newTemplatesQuery** Consider adding validation for the `Creator` field if it's not empty. This can help prevent iss...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Use pointer receivers for methods on `Precompile`** Consider changing the receiver type for methods on `Precompile` from value receivers `(p Precompile...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Use `ID` instead of `Id` in identifiers** According to Go naming conventions, abbreviations like "ID" should be capitalized consistently. Consider rena...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Use `ID` instead of `Id` in identifiers** According to Go naming conventions, abbreviations like "ID" should be capitalized consistently. Consider rena...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Enhance input validation in newActionsByAddressQuery** Consider adding validation for `input.Address` before constructing the request. Invalid addresse...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Use standard naming conventions for error variables to improve code readability.** The variable `e` is used to store errors, but the standard convention in Go is to ...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Check for potential nil pointer dereferences when using addresses.** In several functions, addresses are used after conversion from Bech32 strings without checking i...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Include the invalid key type in the error message for better debugging.** When returning an error due to an unsupported key type, including the invalid `keyType` val...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Refactor duplicated code across event mapping functions to improve maintainability.** Many of the event mapping functions share similar code patterns f...

View on GitHub

Load more