Ecosyste.ms: Timeline

Browse the timeline of events for every public repo on GitHub. Data updated hourly from GH Archive.

warden-protocol/wardenprotocol

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Index `templateId` in the `UpdateTemplate` event for consistent querying.** Adding `indexed` to `templateId` allows for streamlined filtering of templa...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Index `templateId` in the `CreateTemplate` event to facilitate event queries.** By indexing `templateId`, you enable more efficient querying of templat...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Use Correct Capitalization for Initialisms in Struct Field Names** According to the [Uber Go Style Guide](https://github.com/uber-go/guide/blob/master/...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Correct the error message to match the variable name.** The error message in `newMsgAddKeychainWriter` refers to `newAdminAddress`, but the variable is `newWriterAdd...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Validate `Status` field before converting to enum** In `newKeyRequestsRequest`, `input.Status` is directly cast to `types.KeyRequestStatus` without validation. This ...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Handle potential nil `KeybaseId.Value` to prevent nil pointer dereference** In `mapKeychain`, when `keychain.KeybaseId` is not nil, you assign `keybaseId = keychain....

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Validate `Status` field before converting to enum** In `newSignRequestsRequest`, `input.Status` is directly cast to `types.SignRequestStatus` without checking if it'...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Use 'ID' instead of 'Id' in identifier names** Consistent capitalization of initialisms improves code clarity. Rename `templateId` to `templateID` as p...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Use 'ID' instead of 'Id' in identifier names** To follow the initialism capitalization rules, change `actionId` to `actionID`. Apply this diff: ```...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Update function comments to start with the function name** Per the Go conventions and the [Uber Go Style Guide](https://github.com/uber-go/guide/blob/m...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Use 'ID' instead of 'Id' in identifier names** In line with the Uber Go Style Guide, please rename `actionId` to `actionID` to maintain consistency wit...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Update function comments to start with the function name** Ensure that comments for exported functions begin with the function name to adhere to Go doc...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Use 'ID' instead of 'Id' in identifier names** According to the [Uber Go Style Guide](https://github.com/uber-go/guide/blob/master/style.md#initialisms...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Update function comments to start with the function name** Starting comments with the function name improves consistency and aids documentation generat...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Update function comments to start with the function name** As per the Go conventions, function comments should start with the name of the function. Thi...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Update function comments to start with the function name** Comments for exported functions should begin with the function's name as per Go conventions ...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Validate 'voteType' value to ensure it's within expected range** While you ensure `voteType` is of type `uint8`, there is no check to confirm that it matches valid `...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Handle potential Unicode issues in string arguments** When working with strings that may contain Unicode characters, it's important to ensure they are handled correc...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Avoid using `panic`; return an error instead** Using `panic` for standard error handling is discouraged in Go, as it can lead to unexpected crashes. Instead, conside...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Consider refactoring the large switch-case in `Run` method** The `Run` method has a large switch-case statement that could be simplified or refactored ...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Return `ActionStatus` enum instead of `string` in `checkAction`.** The `checkAction` function returns a `string`, which might lead to inconsistencies or errors due t...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Ensure consistent parameter naming in events for clarity.** The events `CreateTemplate`, `UpdateTemplate`, `CreateAction`, and `ActionStateChange` use ...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Use `ActionStatus` enum instead of `int32` for the `status` parameter.** In the function `actionsByAddress`, the `status` parameter is currently of typ...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Group imports according to Go conventions** The imports are not properly grouped. According to the Go conventions and the [Uber Go Style Guide](https:/...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Avoid panicking; handle unknown methods gracefully** Panicking when an unknown method is encountered can lead to undesirable behavior. It's recommended to return an ...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Enhance error handling in ActionsByAddressQuery and its helper** Consider improving error handling in both the main function and its helper to provide ...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Enhance error handling in TemplatesQuery and its helper** Consider improving error handling in both the main function and its helper to provide more sp...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Enhance error handling in TemplateByIdQuery and its helper** Consider improving error handling in both the main function and its helper to provide more...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Enhance error handling in newActionsQuery** Consider adding more specific error handling when unpacking args to the ActionsInput struct. This will prov...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Use `%w` to wrap errors for better error unwrapping** When wrapping errors with `fmt.Errorf`, use `%w` instead of `%s` to allow error unwrapping, as recommended in G...

View on GitHub

Load more