Ecosyste.ms: Timeline

Browse the timeline of events for every public repo on GitHub. Data updated hourly from GH Archive.

warden-protocol/wardenprotocol

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Avoid using `init()` function; register tests explicitly** The use of `init()` functions is discouraged as it can obscure the program's flow and make it harder to un...

View on GitHub

coderabbitai[bot] created a review on a pull request on warden-protocol/wardenprotocol
**Actionable comments posted: 9** <details> <summary>๐Ÿงน Outside diff range and nitpick comments (1)</summary><blockquote> <details> <summary>tests/cases/warden_precompile_action.go (1)</summary><b...

View on GitHub

coderabbitai[bot] created a review on a pull request on warden-protocol/wardenprotocol
**Actionable comments posted: 9** <details> <summary>๐Ÿงน Outside diff range and nitpick comments (1)</summary><blockquote> <details> <summary>tests/cases/warden_precompile_action.go (1)</summary><b...

View on GitHub

DaevMithran starred warden-protocol/wardenprotocol
coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Typographical Error in Parameter Description** In the `RemoveSpaceOwner` event, the `@param` description for `removedOwner` incorrectly states "The new owner address...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Inconsistent Parameter Naming in Functions** The parameters `Id` in the functions `keyById` and `keyRequestById` start with an uppercase letter. In Solidity, paramet...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Inconsistent Naming Conventions in Struct Members** The member variables in your structs are starting with uppercase letters. According to Solidity conventions, stru...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Consistently check for `nil` when assigning pagination** In some `FromResponse` methods, `res.Pagination` is assigned without checking for `nil`, which could lead to...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Safely perform type assertions to avoid panics** In the following code, performing a type assertion without checking can lead to a panic if the assertion fails: ```...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Simplify repetitive mapping in `FromResponse` methods** The `FromResponse` methods contain repetitive code for mapping fields from response structs to ...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Refactor repetitive argument validation and unpacking** Multiple functions such as `newAllKeysRequest`, `newKeyByIdRequest`, `newKeysBySpaceIdRequest`,...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Organize imports according to standard Go conventions** As per the Uber Go Style Guide, imports should be grouped into three sections separated by blan...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Avoid using 'time.Sleep' in tests; use synchronization mechanisms** Using fixed delays with `time.Sleep` in tests can make tests flaky or unnecessarily...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Typo in method name 'WaitRunnning'** There is a typo in the method name `WaitRunnning`. The correct method name should be `WaitRunning`. This typo will lead to a com...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Use 't.Fatal' or 'require.NoError' instead of 'panic' in tests** Using `panic` in tests is discouraged as it can lead to abrupt termination and less in...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Simplify error handling with 'require.NoError'** In your test code, instead of checking `if err != nil { t.Fatal(err) }`, you can use `require.NoError(...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Consider optimizing NewKey event for better filtering and type safety** The `NewKey` event provides comprehensive information about a new key. However,...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Consider refactoring complex functions and standardizing integer types** 1. The `newKeyRequest` function has a large number of parameters, which might ...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:bulb: Codebase verification_ _:warning: Potential issue_ **Address the commented-out `keychain_fees` handling in the GetUpdateKeychainEvent function.** 1. The `keychain_fees` field is active...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Update error message prefixes, improve variable naming, and standardize attribute keys in GetNewKeyRequestEvent function.** 1. The error message prefixes are inconsi...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Update error message prefixes and improve variable naming in GetNewSpaceEvent function.** 1. The error message prefixes are inconsistent with the function name. 2. S...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Update error message prefixes and improve variable naming in GetRemoveKeychainAdminEvent function.** 1. The error message prefixes are inconsistent with the function...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Update error message prefix in GetNewKeychainEvent function.** The error message prefix is inconsistent with the function name. It should be updated to match the fun...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Improve consistency in GetAddKeychainAdminEvent function.** 1. The parameter `eventAddKeychainWriter` should be renamed to `eventAddKeychainAdmin` to match its purpo...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Update error message prefix and improve variable naming in GetRemoveSpaceOwnerEvent function.** 1. The error message prefix is inconsistent with the function name. 2...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Update error message prefix and improve variable naming in GetAddSpaceOwnerEvent function.** 1. The error message prefix is inconsistent with the function name. 2. S...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Refactor suggestion: Improve consistency and reduce duplication in event handling functions.** While the event handling functions are generally well-st...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Fix typo and improve consistency in GetAddKeychainWriterEvent function.** 1. The parameter `writerAddres` has a typo and should be `writerAddress`. 2. Error message ...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:warning: Potential issue_ **Fix typo in constant name** There's a typo in one of the constant names. `SpacesMethodMethod` should be `SpacesMethod`. Please apply the following change: ```diff...

View on GitHub

coderabbitai[bot] created a review comment on a pull request on warden-protocol/wardenprotocol
_:hammer_and_wrench: Refactor suggestion_ **Suggestion: Optimize slice allocation** The `mapSdkCoins` function is well-implemented and correctly converts `sdkTypes.Coins` to a slice of local `Coi...

View on GitHub

Load more