Ecosyste.ms: Timeline

Browse the timeline of events for every public repo on GitHub. Data updated hourly from GH Archive.

posit-dev/py-shiny

gadenbuie created a review comment on a pull request on posit-dev/py-shiny
It's currently ```suggestion markdown_stream_ui('${message.id}') in the UI (Core)?`, ``` but I like `output_markdown_stream()` better (unless you've already considered and moved away ...

View on GitHub

gadenbuie created a review comment on a pull request on posit-dev/py-shiny
Could we call this `output_markdown_stream()`? That feels like a better fit, or at least to fit with most user expectations. I think I'd rather `ui.output_markdown_stream()` than `ui.markdown_strea...

View on GitHub

gadenbuie created a review on a pull request on posit-dev/py-shiny

View on GitHub

gadenbuie created a review comment on a pull request on posit-dev/py-shiny
```suggestion if (!customElements.get("shiny-markdown-stream")) { customElements.define("shiny-markdown-stream", MarkdownElement); } ``` Minor nit: I find this version easier to read while...

View on GitHub

gadenbuie created a review on a pull request on posit-dev/py-shiny

View on GitHub

gadenbuie created a review comment on a pull request on posit-dev/py-shiny
Is it possible to change this choice after you've created the UI element? It's worth considering. Or maybe it's that this feels like it's in the wrong place, since the message is the thing that'...

View on GitHub

gadenbuie created a review on a pull request on posit-dev/py-shiny

View on GitHub

cpsievert pushed 1 commit to markdown-stream-component posit-dev/py-shiny
  • Missed a couple renamings 37257ec

View on GitHub

gadenbuie created a review comment on a pull request on posit-dev/py-shiny
I think it's worth considering having either a `.set()` method (or better named) or at least including in the docs that `.stream([content])` can be used to set the content. Primarily because we all...

View on GitHub

gadenbuie created a review on a pull request on posit-dev/py-shiny

View on GitHub

gadenbuie created a review comment on a pull request on posit-dev/py-shiny
I'm going to stop calling this out; I think it's worth doing a quick review of all uses.

View on GitHub

gadenbuie created a review comment on a pull request on posit-dev/py-shiny
To touch on "markdown stream" one more time, I don't think it's a great term to describe the UI or component that's in the app. One option could be to just capitalize "Markdown Stream". Otherwise, ...

View on GitHub

gadenbuie created a review on a pull request on posit-dev/py-shiny

View on GitHub

cpsievert created a review comment on a pull request on posit-dev/py-shiny
No, I don't think we want to support that since, if there are multiple user sessions, they would be mutating the same object

View on GitHub

cpsievert created a review on a pull request on posit-dev/py-shiny

View on GitHub

gadenbuie created a review comment on a pull request on posit-dev/py-shiny
Would the Shiny Express pattern work in Core? ```python md = ui.MarkdownStream("readme") ui = ui.page_fluid( md.ui() ) def server(input, output, session): # Read in the README....

View on GitHub

gadenbuie created a review on a pull request on posit-dev/py-shiny

View on GitHub

gadenbuie created a review comment on a pull request on posit-dev/py-shiny
```suggestion Create a UI element for this markdown stream. ```

View on GitHub

gadenbuie created a review on a pull request on posit-dev/py-shiny

View on GitHub

cpsievert pushed 1 commit to markdown-stream-component posit-dev/py-shiny
  • More aggressively update scrollable element. Add test for obtaining streaming result 6b1e24d

View on GitHub

gadenbuie created a review comment on a pull request on posit-dev/py-shiny
```suggestion A component for streaming markdown or HTML content. ``` Trying to avoid noun/verb confusion around "stream". To me, a class describes a _noun_ but _stream_ here is used as a ...

View on GitHub

gadenbuie created a review on a pull request on posit-dev/py-shiny

View on GitHub

gadenbuie created a review on a pull request on posit-dev/py-shiny

View on GitHub

gadenbuie created a review comment on a pull request on posit-dev/py-shiny
The use of "markdown stream" here gave me pause. I think it should either be a proper noun, like `MarkdownStream`, or it should name more concretely what it identifies. For me, the confusion is aro...

View on GitHub

gadenbuie created a review comment on a pull request on posit-dev/py-shiny
Not something to handle in this PR, but we should anticipate highlighting styles being something that people will want to configure.

View on GitHub

gadenbuie created a review on a pull request on posit-dev/py-shiny

View on GitHub

Aneeqasif starred posit-dev/py-shiny
cpsievert pushed 1 commit to markdown-stream-component posit-dev/py-shiny
  • Have the stream task return the accumulated string result 5089b99

View on GitHub

cpsievert pushed 2 commits to markdown-stream-component posit-dev/py-shiny
  • Tweak example code 3413029
  • Have .stream() return the ExtendedTask; Add a .clear() method 833edfc

View on GitHub

karangattu created a branch on posit-dev/py-shiny

add-issue-template - Shiny for Python

Load more